GLSA-200609-07 : LibXfont, monolithic Multiple integer overflows

High Nessus Plugin ID 22352


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200609-07 (LibXfont, monolithic Multiple integer overflows)

Several integer overflows have been found in the CID font parser.
Impact :

A remote attacker could exploit this vulnerability by enticing a user to load a malicious font file resulting in the execution of arbitrary code with the permissions of the user running the X server which typically is the root user. A local user could exploit this vulnerability to gain elevated privileges.
Workaround :

Disable CID-encoded Type 1 fonts by removing the 'type1' module and replacing it with the 'freetype' module in xorg.conf.


All libXfont users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXfont-1.2.1' All monolithic users are advised to migrate to modular

See Also

Plugin Details

Severity: High

ID: 22352

File Name: gentoo_GLSA-200609-07.nasl

Version: $Revision: 1.16 $

Type: local

Published: 2006/09/15

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libXfont, p-cpe:/a:gentoo:linux:xorg-x11, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/09/13

Vulnerability Publication Date: 2006/09/12

Reference Information

CVE: CVE-2006-3739, CVE-2006-3740

BID: 19974

OSVDB: 28738, 28739

GLSA: 200609-07