Quicktime < 7.1.3 Multiple Vulnerabilities (Mac OS X)

Medium Nessus Plugin ID 22335


The remote version of QuickTime is affected by multiple overflow vulnerabilities.


The remote Mac OS X host is running a version of Quicktime prior to 7.1.3.

The remote version of Quicktime is vulnerable to various integer and buffer overflows involving specially crafted image and media files. An attacker may be able to leverage these issues to execute arbitrary code on the remote host by sending a malformed file to a victim and having him open it using QuickTime player.


Upgrade to Quicktime version 7.1.3 or later.

See Also


Plugin Details

Severity: Medium

ID: 22335

File Name: macosx_Quicktime713.nasl

Version: $Revision: 1.13 $

Type: local

Agent: macosx

Published: 2006/09/13

Modified: 2013/03/04

Dependencies: 15573

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/09/08

Vulnerability Publication Date: 2006/09/12

Reference Information

CVE: CVE-2006-4381, CVE-2006-4382, CVE-2006-4384, CVE-2006-4385, CVE-2006-4386, CVE-2006-4388, CVE-2006-4389

BID: 19976

OSVDB: 28768, 28769, 28770, 28771, 28772, 28773, 28774