GLSA-200609-05 : OpenSSL, AMD64 x86 emulation base libraries: RSA signature forgery

Medium Nessus Plugin ID 22327


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200609-05 (OpenSSL, AMD64 x86 emulation base libraries: RSA signature forgery)

Daniel Bleichenbacher discovered that it might be possible to forge signatures signed by RSA keys with the exponent of 3.
Impact :

Since several CAs are using an exponent of 3 it might be possible for an attacker to create a key with a false CA signature.
Workaround :

There is no known workaround at this time.


All OpenSSL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/openssl-0.9.7k' All AMD64 x86 emulation base libraries users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-emulation/emul-linux-x86-baselibs-2.5.2'

See Also

Plugin Details

Severity: Medium

ID: 22327

File Name: gentoo_GLSA-200609-05.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2006/09/12

Modified: 2016/05/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:emul-linux-x86-baselibs, p-cpe:/a:gentoo:linux:openssl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list, Host/Gentoo/arch

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/09/07

Vulnerability Publication Date: 2006/09/05

Reference Information

CVE: CVE-2006-4339

BID: 19849

OSVDB: 28549

GLSA: 200609-05

CWE: 310