PmWiki < 2.1.21 Global Variables Overwriting

high Nessus Plugin ID 22310
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote web server contains a PHP script that is affected by a global variable overwriting vulnerability.

Description

The version of PmWiki installed on the remote host contains a programming flaw in 'pmwiki.php' that may allow an unauthenticated remote attacker to overwrite global variables used by the application, which could in turn be exploited to execute arbitrary PHP code on the affected host, subject to the privileges of the web server user id.

Note that successful exploitation of this issue requires that PHP's 'register_globals' and 'file_uploads' settings be enabled and that the remote version of PHP be older than 4.4.3 or 5.1,4.

Solution

Upgrade to PmWiki version 2.1.21 or later.

See Also

http://www.nessus.org/u?ccaf872d

http://www.pmwiki.com/wiki/PmWiki/ReleaseNotes

Plugin Details

Severity: High

ID: 22310

File Name: pmwiki_globals_overwrite.nasl

Version: 1.19

Type: remote

Family: CGI abuses

Published: 9/6/2006

Updated: 1/19/2021

Dependencies: http_version.nasl

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:pmwiki:pmwiki

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Vulnerability Publication Date: 5/1/2006

Reference Information

CVE: CVE-2006-3017

BID: 17843