e107 ibrowser.php zend_has_del() Function Remote Code Execution

high Nessus Plugin ID 22299
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote web server contains a PHP script that allows execution of arbitrary PHP code.

Description

The 'e107_handlers/tiny_mce/plugins/ibrowser/ibrowser.php' script included with the version of e107 installed on the remote host contains a programming flaw that may allow an unauthenticated, remote attacker to execute arbitrary PHP code on the affected host, subject to the privileges of the web server user id.

Note that successful exploitation of this issue requires that PHP's 'register_globals' and 'file_uploads' settings be enabled and that the remote version of PHP be older than 4.4.1 or 5.0.6.

Solution

Upgrade to PHP version 4.4.3 / 5.1.3 or later.

See Also

http://www.hardened-php.net/globals-problem

http://www.nessus.org/u?ccaf872d

Plugin Details

Severity: High

ID: 22299

File Name: e107_globals_overwrite.nasl

Version: 1.32

Type: remote

Family: CGI abuses

Published: 9/2/2006

Updated: 1/19/2021

Dependencies: e107_detect.nasl, os_fingerprint.nasl

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:e107:e107

Required KB Items: www/e107

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 5/2/2006

Vulnerability Publication Date: 5/1/2006

Reference Information

CVE: CVE-2005-3390, CVE-2006-3017

BID: 15250, 17843

EDB-ID: 2268