GLSA-200608-28 : PHP: Arbitary code execution

Medium Nessus Plugin ID 22290

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200608-28 (PHP: Arbitary code execution)

The sscanf() PHP function contains an array boundary error that can be exploited to dereference a NULL pointer. This can possibly allow the bypass of the safe mode protection by executing arbitrary code.
Impact :

A remote attacker might be able to exploit this vulnerability in PHP applications making use of the sscanf() function, potentially resulting in the execution of arbitrary code or the execution of scripted contents in the context of the affected site.
Workaround :

There is no known workaround at this time.

Solution

All PHP 4.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-4.4.3-r1' All PHP 5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.1.4-r6'

See Also

https://security.gentoo.org/glsa/200608-28

Plugin Details

Severity: Medium

ID: 22290

File Name: gentoo_GLSA-200608-28.nasl

Version: 1.15

Type: local

Published: 2006/08/30

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.6

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:php, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/08/29

Vulnerability Publication Date: 2006/08/04

Reference Information

CVE: CVE-2006-4020

BID: 19415

GLSA: 200608-28