CentOS 4 : xorg-x11 (CESA-2006:0634)

High Nessus Plugin ID 22281

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated X.org packages that fix a security issue are now available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red Hat Security Response Team.

X.org is an open source implementation of the X Window System. It provides the basic low-level functionality that full-fledged graphical user interfaces are designed upon.

An integer overflow flaw in the way the X.org server processes PCF files was discovered. A malicious authorized client could exploit this issue to cause a denial of service (crash) or potentially execute arbitrary code with root privileges on the X.org server.
(CVE-2006-3467)

Users of X.org should upgrade to these updated packages, which contain a backported patch and is not vulnerable to this issue.

Solution

Update the affected xorg-x11 packages.

See Also

http://www.nessus.org/u?f6a8b33a

http://www.nessus.org/u?21204fab

http://www.nessus.org/u?0d9fb270

Plugin Details

Severity: High

ID: 22281

File Name: centos_RHSA-2006-0634.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2006/08/30

Updated: 2019/10/03

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:centos:centos:xorg-x11, p-cpe:/a:centos:centos:xorg-x11-Mesa-libGL, p-cpe:/a:centos:centos:xorg-x11-Mesa-libGLU, p-cpe:/a:centos:centos:xorg-x11-Xdmx, p-cpe:/a:centos:centos:xorg-x11-Xnest, p-cpe:/a:centos:centos:xorg-x11-Xvfb, p-cpe:/a:centos:centos:xorg-x11-deprecated-libs, p-cpe:/a:centos:centos:xorg-x11-deprecated-libs-devel, p-cpe:/a:centos:centos:xorg-x11-devel, p-cpe:/a:centos:centos:xorg-x11-doc, p-cpe:/a:centos:centos:xorg-x11-font-utils, p-cpe:/a:centos:centos:xorg-x11-libs, p-cpe:/a:centos:centos:xorg-x11-sdk, p-cpe:/a:centos:centos:xorg-x11-tools, p-cpe:/a:centos:centos:xorg-x11-twm, p-cpe:/a:centos:centos:xorg-x11-xauth, p-cpe:/a:centos:centos:xorg-x11-xdm, p-cpe:/a:centos:centos:xorg-x11-xfs, cpe:/o:centos:centos:4

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Patch Publication Date: 2006/08/23

Vulnerability Publication Date: 2006/07/21

Reference Information

CVE: CVE-2006-3467

RHSA: 2006:0634