IBM eGatherer ActiveX RunEgatherer Function Overflow

High Nessus Plugin ID 22253


The remote Windows host has an ActiveX control that is affected by a buffer overflow vulnerability.


The Windows remote host contains the eGatherer ActiveX control, which is typically installed by default on IBM workstations and laptops and used for automatically locating drivers and updates on IBM / Lenovo support sites.

The version of this ActiveX control on the remote host reportedly contains a stack-based buffer overflow in the 'RunEgatherer' function.
Exploitation of this issue may allow an unauthenticated remote attacker to execute arbitrary code subject to the user's privileges.


Upgrade to version or later of the ActiveX control.

See Also

Plugin Details

Severity: High

ID: 22253

File Name: egatherer_runegatherer_activex_overflow.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2006/08/21

Modified: 2016/10/10

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2006/08/16

Vulnerability Publication Date: 2006/08/16

Reference Information

CVE: CVE-2006-4221

BID: 19554

OSVDB: 27976