GLSA-200608-10 : pike: SQL injection vulnerability

High Nessus Plugin ID 22168


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200608-10 (pike: SQL injection vulnerability)

Some input is not properly sanitised before being used in a SQL statement in the underlying PostgreSQL database.
Impact :

A remote attacker could provide malicious input to a pike program, which might result in the execution of arbitrary SQL statements.
Workaround :

There is no known workaround at this time.


All pike users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/pike-7.6.86'

See Also

Plugin Details

Severity: High

ID: 22168

File Name: gentoo_GLSA-200608-10.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/08/07

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pike, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/08/06

Vulnerability Publication Date: 2006/06/06

Reference Information

CVE: CVE-2006-4041

OSVDB: 26238

GLSA: 200608-10