GLSA-200608-01 : Apache: Off-by-one flaw in mod_rewrite

High Nessus Plugin ID 22143

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.9

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-200608-01 (Apache: Off-by-one flaw in mod_rewrite)

An off-by-one flaw has been found in Apache's mod_rewrite module by Mark Dowd of McAfee Avert Labs. This flaw is exploitable depending on the types of rewrite rules being used.
Impact :

A remote attacker could exploit the flaw to cause a Denial of Service or execution of arbitrary code. Note that Gentoo Linux is not vulnerable in the default configuration.
Workaround :

There is no known workaround at this time.

Solution

All Apache users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose www-servers/apache

See Also

http://www.apache.org/dist/httpd/Announcement2.0.html

http://www.nessus.org/u?a26cbb9f

https://security.gentoo.org/glsa/200608-01

Plugin Details

Severity: High

ID: 22143

File Name: gentoo_GLSA-200608-01.nasl

Version: 1.17

Type: local

Published: 2006/08/04

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 4.9

CVSS v2.0

Base Score: 7.6

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:apache, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/08/01

Vulnerability Publication Date: 2006/07/28

Exploitable With

Core Impact

Metasploit (Apache Module mod_rewrite LDAP Protocol Buffer Overflow)

Reference Information

CVE: CVE-2006-3747

GLSA: 200608-01

CWE: 189