GLSA-200607-08 : GIMP: Buffer overflow

Medium Nessus Plugin ID 22106


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200607-08 (GIMP: Buffer overflow)

Henning Makholm discovered that the 'xcf_load_vector()' function is vulnerable to a buffer overflow when loading a XCF file with a large 'num_axes' value.
Impact :

An attacker could exploit this issue to execute arbitrary code by enticing a user to open a specially crafted XCF file.
Workaround :

There is no known workaround at this time.


All GIMP users should update to the latest stable version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/gimp-2.2.12'

See Also

Plugin Details

Severity: Medium

ID: 22106

File Name: gentoo_GLSA-200607-08.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/07/28

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gimp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/07/23

Vulnerability Publication Date: 2006/07/06

Reference Information

CVE: CVE-2006-3404

BID: 18877

OSVDB: 27037

GLSA: 200607-08