WinGate IMAP Server Directory Traversal Vulnerabilities

Medium Nessus Plugin ID 22022


The remote IMAP server is prone to multiple directory traversal vulnerabilities.


The remote host appears to be running WinGate, a Windows application for managing and securing Internet access.

The version of WinGate installed on the remote host fails to remove directory traversal sequences from the 'CREATE', 'SELECT', 'DELETE', 'RENAME', 'COPY', 'APPEND', and 'LIST' commands before using them to access messages. An authenticated attacker may be able to exploit this issue to read mail belong to other users and to create / rename / delete arbitrary directories on the affected system.


Upgrade to WinGate 6.1.4 Build 1099 or later.

See Also

Plugin Details

Severity: Medium

ID: 22022

File Name: wingate_614.nasl

Version: $Revision: 1.15 $

Type: remote

Agent: windows

Family: Windows

Published: 2006/07/11

Modified: 2015/09/24

Dependencies: 10125

Risk Information

Risk Factor: Medium


Base Score: 5.5

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:C

Vulnerability Information

Required KB Items: imap/login, imap/password

Excluded KB Items: imap/false_imap, imap/overflow

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Vulnerability Publication Date: 2006/07/10

Reference Information

CVE: CVE-2006-2917

BID: 18908

OSVDB: 27114