GLSA-200607-02 : FreeType: Multiple integer overflows

High Nessus Plugin ID 22009


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200607-02 (FreeType: Multiple integer overflows)

Multiple integer overflows exist in a variety of files (bdf/bdflib.c, sfnt/ttcmap.c, cff/cffgload.c, base/ftmac.c).
Impact :

A remote attacker could exploit these buffer overflows by enticing a user to load a specially crafted font, which could result in the execution of arbitrary code.
Workaround :

There is no known workaround at this time.


All FreeType users should upgrade to the latest stable version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-libs/freetype-2.1.10-r2'

See Also

Plugin Details

Severity: High

ID: 22009

File Name: gentoo_GLSA-200607-02.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/07/10

Modified: 2017/08/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:freetype, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/07/09

Vulnerability Publication Date: 2006/05/02

Reference Information

CVE: CVE-2006-1861

OSVDB: 25654, 41724, 41725, 41726

GLSA: 200607-02