CentOS 4 : kdegraphics (CESA-2005:868)

critical Nessus Plugin ID 21972
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated kdegraphics packages that resolve several security issues in kpdf are now available.

This update has been rated as having important security impact by the Red Hat Security Response Team.

The kdegraphics packages contain applications for the K Desktop Environment including kpdf, a pdf file viewer.

Several flaws were discovered in kpdf. An attacker could construct a carefully crafted PDF file that could cause kpdf to crash or possibly execute arbitrary code when opened. The Common Vulnerabilities and Exposures project assigned the names CVE-2005-3191, CVE-2005-3192, and CVE-2005-3193 to these issues.

Users of kpdf should upgrade to these updated packages, which contain a backported patch to resolve these issues.

Solution

Update the affected kdegraphics packages.

See Also

http://www.nessus.org/u?5019810d

http://www.nessus.org/u?ba16ee6d

http://www.nessus.org/u?0038b4d7

Plugin Details

Severity: Critical

ID: 21972

File Name: centos_RHSA-2005-868.nasl

Version: 1.18

Type: local

Agent: unix

Published: 7/5/2006

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: Critical

VPR Score: 6.7

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:kdegraphics, p-cpe:/a:centos:centos:kdegraphics-devel, cpe:/o:centos:centos:4

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 12/20/2005

Vulnerability Publication Date: 12/6/2005

Reference Information

CVE: CVE-2005-3191, CVE-2005-3192, CVE-2005-3193, CVE-2005-3624, CVE-2005-3625, CVE-2005-3626, CVE-2005-3627, CVE-2005-3628

BID: 15721, 15725, 15726, 15727

RHSA: 2005:868