RHEL 3 / 4 : squirrelmail (RHSA-2006:0547)

High Nessus Plugin ID 21915


The remote Red Hat host is missing a security update.


An updated squirrelmail package that fixes a local file disclosure flaw is now available.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

SquirrelMail is a standards-based webmail package written in PHP4.

A local file disclosure flaw was found in the way SquirrelMail loads plugins. In SquirrelMail 1.4.6 or earlier, if register_globals is on and magic_quotes_gpc is off, it became possible for an unauthenticated remote user to view the contents of arbitrary local files the web server has read-access to. This configuration is neither default nor safe, and configuring PHP with the register_globals set on is dangerous and not recommended. (CVE-2006-2842)

Users of SquirrelMail should upgrade to this erratum package, which contains a backported patch to correct this issue.


Update the affected squirrelmail package.

See Also





Plugin Details

Severity: High

ID: 21915

File Name: redhat-RHSA-2006-0547.nasl

Version: $Revision: 1.16 $

Type: local

Agent: unix

Published: 2006/07/04

Modified: 2016/12/29

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:squirrelmail, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2006/07/03

Vulnerability Publication Date: 2006/05/31

Reference Information

CVE: CVE-2006-2842

OSVDB: 25973

RHSA: 2006:0547