OpenOffice < 2.0.3 Multiple Vulnerabilities

High Nessus Plugin ID 21784


Arbitrary code can be executed on the remote host through


The remote host is running a version of which is older than version 2.0.3.

An attacker may use this to execute arbitrary code on this host.

To succeed, the attacker would have to send a rogue file to a user of the remote computer and have him open it. The file could be crafted in such a way that it could exploit a buffer overflow in's XML parser, or by containing rogue macros.


Upgrade to 2.0.3 or newer.

See Also

Plugin Details

Severity: High

ID: 21784

File Name: openoffice_org_203.nasl

Version: $Revision: 1.17 $

Type: local

Agent: windows

Family: Windows

Published: 2006/06/30

Modified: 2016/12/07

Dependencies: 25551

Risk Information

Risk Factor: High


Base Score: 7.6

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/

Required KB Items: SMB/OpenOffice/Build

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/07/30

Vulnerability Publication Date: 2006/06/30

Reference Information

CVE: CVE-2006-3117, CVE-2006-2198, CVE-2006-2199

BID: 18737, 18738, 18739

OSVDB: 26939, 26940, 26941, 26942, 26943, 26944, 26945