Mandrake Linux Security Advisory : MySQL (MDKSA-2006:111)

Medium Nessus Plugin ID 21755


The remote Mandrake Linux host is missing one or more security updates.


Mysqld in MySQL 4.1.x before 4.1.18, 5.0.x before 5.0.19, and 5.1.x before 5.1.6 allows remote authorized users to cause a denial of service (crash) via a NULL second argument to the str_to_date function.

MySQL 4.0.18 in Corporate 3.0 and MNF 2.0 is not affected by this issue.

Packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 21755

File Name: mandrake_MDKSA-2006-111.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/06/24

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:MySQL, p-cpe:/a:mandriva:linux:MySQL-Max, p-cpe:/a:mandriva:linux:MySQL-NDB, p-cpe:/a:mandriva:linux:MySQL-bench, p-cpe:/a:mandriva:linux:MySQL-client, p-cpe:/a:mandriva:linux:MySQL-common, p-cpe:/a:mandriva:linux:lib64mysql14, p-cpe:/a:mandriva:linux:lib64mysql14-devel, p-cpe:/a:mandriva:linux:libmysql14, p-cpe:/a:mandriva:linux:libmysql14-devel, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/06/23

Reference Information

CVE: CVE-2006-3081

MDKSA: 2006:111