Mandrake Linux Security Advisory : gnupg (MDKSA-2006:110)

Medium Nessus Plugin ID 21754


The remote Mandrake Linux host is missing one or more security updates.


A vulnerability was discovered in GnuPG 1.4.3 and 1.9.20 (and earlier) that could allow a remote attacker to cause gpg to crash and possibly overwrite memory via a message packet with a large length.

The updated packages have been patched to correct these issues.


Update the affected gnupg and / or gnupg2 packages.

Plugin Details

Severity: Medium

ID: 21754

File Name: mandrake_MDKSA-2006-110.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/06/24

Modified: 2015/03/19

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnupg, p-cpe:/a:mandriva:linux:gnupg2, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/06/20

Reference Information

CVE: CVE-2006-3082

BID: 18554

MDKSA: 2006:110