GLSA-200606-22 : aRts: Privilege escalation

Medium Nessus Plugin ID 21742


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200606-22 (aRts: Privilege escalation)

artswrapper fails to properly check whether it can drop privileges accordingly if setuid() fails due to a user exceeding assigned resource limits.
Impact :

Local attackers could exploit this vulnerability to execute arbitrary code with elevated privileges. Note that the aRts package provided by Gentoo is only vulnerable if the artswrappersuid USE-flag is enabled.
Workaround :

There is no known workaround at this time.


All aRts users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose kde-base/arts

See Also

Plugin Details

Severity: Medium

ID: 21742

File Name: gentoo_GLSA-200606-22.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/06/23

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:L/AC:H/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:arts, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/06/22

Vulnerability Publication Date: 2006/06/14

Reference Information

CVE: CVE-2006-2916

BID: 18429

OSVDB: 26506

GLSA: 200606-22