MS06-028: Vulnerabilities in Microsoft PowerPoint Could Allow Remote Code Execution (916768)

high Nessus Plugin ID 21691

Synopsis

Arbitrary code can be executed on the remote host through Microsoft PowerPoint.

Description

The remote host is running a version of Microsoft PowerPoint that is subject to a fla that could allow arbitrary code to be run.

An attacker may use this to execute arbitrary code on this host.

To succeed, the attacker would have to send a rogue file to a user of the remote computer and have it open it. Then a bug in the font parsing handler would result in code execution.

Solution

Microsoft has released a set of patches for PowerPoint 2000, XP and 2003.

See Also

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2006/ms06-028

Plugin Details

Severity: High

ID: 21691

File Name: smb_nt_ms06-028.nasl

Version: 1.38

Type: local

Agent: windows

Published: 6/13/2006

Updated: 11/15/2018

Risk Information

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: High

Base Score: 7.6

Temporal Score: 6.6

Vector: AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office, cpe:/a:microsoft:powerpoint

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/13/2006

Vulnerability Publication Date: 6/13/2006

Reference Information

CVE: CVE-2006-0022

BID: 18382

CERT: 190089

MSFT: MS06-028

MSKB: 916768