GLSA-200606-04 : Tor: Several vulnerabilities

Medium Nessus Plugin ID 21671


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200606-04 (Tor: Several vulnerabilities)

Some integer overflows exist when adding elements to the smartlists.
Non-printable characters received from the network are not properly sanitised before being logged. There are additional unspecified bugs in the directory server and in the internal circuits.
Impact :

The possible buffer overflow may allow a remote attacker to execute arbitrary code on the server by sending large inputs. The other vulnerabilities can lead to a Denial of Service, a lack of logged information, or some information disclosure.
Workaround :

There is no known workaround at this time.


All Tor users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose net-misc/tor

See Also

Plugin Details

Severity: Medium

ID: 21671

File Name: gentoo_GLSA-200606-04.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/06/08

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tor, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/06/07

Vulnerability Publication Date: 2006/01/12

Reference Information

CVE: CVE-2006-0414

OSVDB: 22689, 25874, 35673, 35674, 35675

GLSA: 200606-04