SquirrelMail plugin.php plugins Parameter Local File Inclusion

High Nessus Plugin ID 21630

Synopsis

The remote web server contains a PHP script that is affected by a local file include issue.

Description

The version of SquirrelMail installed on the remote web server fails to properly sanitize user-supplied input to the 'plugins' parameter of the 'functions/plugin.php' script before using it in a PHP 'include_once()' function. Provided PHP's 'register_globals' setting is enabled, an unauthenticated attacker may be able to exploit this issue to view arbitrary files or to execute arbitrary PHP code on the remote host, subject to the privileges of the web server user id.

Solution

Disable PHP's 'register_globals' setting or apply the patch referenced in the project's advisory above.

See Also

https://www.securityfocus.com/archive/1/435605/30/0/threaded

http://www.squirrelmail.org/security/issue/2006-06-01

Plugin Details

Severity: High

ID: 21630

File Name: squirrelmail_plugins_file_include.nasl

Version: 1.19

Type: remote

Family: CGI abuses

Published: 2006/06/03

Updated: 2018/11/15

Dependencies: 12647

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:squirrelmail:squirrelmail

Required KB Items: www/squirrelmail

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: false

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2006/05/31

Reference Information

CVE: CVE-2006-2842

BID: 18231