Fenice <= 1.10 Multiple Remote Vulnerabilities

High Nessus Plugin ID 21610


The remote RTSP server suffers from multiple overflow issues.


The remote host is running Fenice, an open source media streaming server for Linux / Unix.

The version of Fenice installed on the remote host is affected by an integer overflow vulnerability involving requests with large values for the 'Content-Length' header and by a buffer overflow vulnerability in its 'parse_url' function. An unauthenticated, remote attacker can exploit either flaw using a simple GET request to crash the affected application and possibly to execute arbitrary code subject to the privileges of the user id under which Fenice runs.


Upgrade to Fenice version 1.11 or later.

See Also



Plugin Details

Severity: High

ID: 21610

File Name: fenice_110.nasl

Version: $Revision: 1.15 $

Type: remote

Published: 2006/05/27

Modified: 2013/01/07

Dependencies: 11153

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ls3:fenice

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/06/06

Vulnerability Publication Date: 2006/04/23

Reference Information

CVE: CVE-2006-2022, CVE-2006-2023

BID: 17678

OSVDB: 24881, 24882