Ubuntu 5.04 / 5.10 : dia vulnerabilities (USN-286-1)

High Nessus Plugin ID 21604


The remote Ubuntu host is missing one or more security-related patches.


Several format string vulnerabilities have been discovered in dia. By tricking a user into opening a specially crafted dia file, or a file with a specially crafted name, this could be exploited to execute arbitrary code with the user's privileges.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 21604

File Name: ubuntu_USN-286-1.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2006/05/27

Modified: 2016/05/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:W/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:dia, p-cpe:/a:canonical:ubuntu_linux:dia-common, p-cpe:/a:canonical:ubuntu_linux:dia-gnome, p-cpe:/a:canonical:ubuntu_linux:dia-libs, cpe:/o:canonical:ubuntu_linux:5.04, cpe:/o:canonical:ubuntu_linux:5.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/05/24

Vulnerability Publication Date: 2006/05/05

Reference Information

CVE: CVE-2006-2453, CVE-2006-2480

BID: 18078

OSVDB: 25699

USN: 286-1

CWE: 134