Mandrake Linux Security Advisory : hostapd (MDKSA-2006:088)

Medium Nessus Plugin ID 21599


The remote Mandrake Linux host is missing a security update.


Hostapd 0.3.7 allows remote attackers to cause a denial of service (segmentation fault) via an unspecified value in the key_data_length field of an EAPoL frame.

Packages have been patched to correct this issue.


Update the affected hostapd package.

Plugin Details

Severity: Medium

ID: 21599

File Name: mandrake_MDKSA-2006-088.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/05/27

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:hostapd, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/05/24

Reference Information

CVE: CVE-2006-2213

MDKSA: 2006:088