FileZilla FTP Server MLSD Command Overflow

Medium Nessus Plugin ID 21567


The remote Windows host has an application that is suffers from a buffer overflow vulnerability.


According to its version, the FileZilla Server Interface installed on the remote host is affected by an unspecified buffer overflow vulnerability, which could be leveraged by an attacker to execute arbitrary code subject to the privileges of the user running the affected application.

Note that to successfully exploit this remotely, the application would need to be configured to accept remote connections, which it does not by default.


Upgrade to FileZilla Server version 0.9.17 or later.

See Also

Plugin Details

Severity: Medium

ID: 21567

File Name: filezilla_server_interface_buffer_overflow.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2006/05/16

Modified: 2017/08/14

Dependencies: 13855

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:filezilla:filezilla_server

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2006/05/02

Reference Information

CVE: CVE-2006-2173

BID: 17802

OSVDB: 25221