QuickTime < 7.1 Multiple Vulnerabilities (Windows)

high Nessus Plugin ID 21556
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote version of QuickTime is affected by multiple overflow vulnerabilities.

Description

The remote Windows host is running a version of QuickTime prior to 7.1.

The remote version of QuickTime is vulnerable to various integer and buffer overflows involving specially crafted image and media files. An attacker may be able to leverage these issues to execute arbitrary code on the remote host by sending a malformed file to a victim and having him open it using QuickTime player.

Solution

Upgrade to QuickTime version 7.1 or later.

See Also

https://lists.apple.com/archives/security-announce/2006/May/msg00002.html

Plugin Details

Severity: High

ID: 21556

File Name: quicktime_71.nasl

Version: 1.22

Type: local

Agent: windows

Family: Windows

Published: 5/15/2006

Updated: 11/15/2018

Dependencies: quicktime_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: SMB/QuickTime/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 5/9/2006

Vulnerability Publication Date: 5/9/2006

Reference Information

CVE: CVE-2006-1249, CVE-2006-1453, CVE-2006-1454, CVE-2006-1458, CVE-2006-1459, CVE-2006-1460, CVE-2006-1461, CVE-2006-1462, CVE-2006-1463, CVE-2006-1464, CVE-2006-1465, CVE-2006-2238

BID: 17074, 17953

CWE: 189