Quicktime < 7.1 Multiple Vulnerabilities (Mac OS X)

high Nessus Plugin ID 21554
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote version of QuickTime is affected by multiple overflow vulnerabilities.


The remote Mac OS X host is running a version of Quicktime prior to 7.1.

The remote version of Quicktime is vulnerable to various integer and buffer overflows involving specially crafted image and media files. An attacker may be able to leverage these issues to execute arbitrary code on the remote host by sending a malformed file to a victim and having him open it using QuickTime player.


Upgrade to Quicktime version 7.1 or later.

See Also






Plugin Details

Severity: High

ID: 21554

File Name: macosx_Quicktime71.nasl

Version: 1.23

Type: local

Agent: macosx

Published: 5/13/2006

Updated: 7/14/2018

Dependencies: macosx_Quicktime652.nasl

Risk Information


Risk Factor: Medium

Score: 5.8


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 5/9/2006

Vulnerability Publication Date: 5/9/2006

Reference Information

CVE: CVE-2006-1249, CVE-2006-1453, CVE-2006-1454, CVE-2006-1458, CVE-2006-1459, CVE-2006-1460, CVE-2006-1461, CVE-2006-1462, CVE-2006-1463, CVE-2006-1464, CVE-2006-1465, CVE-2006-2238

BID: 17074, 17953

CWE: 189