Quicktime < 7.1 Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 21554


The remote version of QuickTime is affected by multiple overflow vulnerabilities.


The remote Mac OS X host is running a version of Quicktime prior to 7.1.

The remote version of Quicktime is vulnerable to various integer and buffer overflows involving specially crafted image and media files. An attacker may be able to leverage these issues to execute arbitrary code on the remote host by sending a malformed file to a victim and having him open it using QuickTime player.


Upgrade to Quicktime version 7.1 or later.

See Also






Plugin Details

Severity: High

ID: 21554

File Name: macosx_Quicktime71.nasl

Version: $Revision: 1.22 $

Type: local

Agent: macosx

Published: 2006/05/13

Modified: 2017/07/19

Dependencies: 15573

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Required KB Items: MacOSX/QuickTime/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/05/09

Vulnerability Publication Date: 2006/05/09

Reference Information

CVE: CVE-2006-1249, CVE-2006-1453, CVE-2006-1454, CVE-2006-1458, CVE-2006-1459, CVE-2006-1460, CVE-2006-1461, CVE-2006-1462, CVE-2006-1463, CVE-2006-1464, CVE-2006-1465, CVE-2006-2238

BID: 17074, 17953

OSVDB: 24820, 25508, 25509, 25510, 25511, 25512, 25513, 25514, 25515, 25516, 25517

CWE: 189