Gene6 FTP Server Multiple Command Remote Overflows

high Nessus Plugin ID 21324
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote FTP server is affected by buffer overflow flaws.

Description

The remote host appears to be using Gene6 FTP Server, a professional FTP server for Windows.

According to its banner, the version of Gene6 FTP Server installed on the remote host contains buffer overflow vulnerabilities that can be exploited by an authenticated, possibly anonymous, user with specially crafted 'MKD', 'RMD', 'XMKD', and 'XRMD' commands to crash the affected application or execute arbitrary code on the affected host.

Solution

Upgrade to Gene6 FTP Server version 3.8.0 or later.

See Also

https://www.securityfocus.com/archive/1/432839/30/0/threaded

http://www.g6ftpserver.com/forum/index.php?showtopic=2515

Plugin Details

Severity: High

ID: 21324

File Name: gene6_380.nasl

Version: 1.17

Type: remote

Family: FTP

Published: 5/4/2006

Updated: 11/15/2018

Dependencies: ftpserver_detect_type_nd_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 5/3/2006

Reference Information

CVE: CVE-2006-2172

BID: 17810