GLSA-200604-14 : Dia: Arbitrary code execution through XFig import

High Nessus Plugin ID 21279


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200604-14 (Dia: Arbitrary code execution through XFig import)

infamous41md discovered multiple buffer overflows in Dia's XFig file import plugin.
Impact :

By enticing a user to import a specially crafted XFig file into Dia, an attacker could exploit this issue to execute arbitrary code with the rights of the user running Dia.
Workaround :

There is no known workaround at this time.


All Dia users should upgrade to the latest available version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-office/dia-0.94-r5'

See Also

Plugin Details

Severity: High

ID: 21279

File Name: gentoo_GLSA-200604-14.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/04/26

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dia, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/04/23

Vulnerability Publication Date: 2006/03/29

Reference Information

CVE: CVE-2006-1550

OSVDB: 24294

GLSA: 200604-14