GLSA-200604-09 : Cyrus-SASL: DIGEST-MD5 Pre-Authentication Denial of Service

Low Nessus Plugin ID 21255


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200604-09 (Cyrus-SASL: DIGEST-MD5 Pre-Authentication Denial of Service)

Cyrus-SASL contains an unspecified vulnerability in the DIGEST-MD5 process that could lead to a Denial of Service.
Impact :

An attacker could possibly exploit this vulnerability by sending specially crafted data stream to the Cyrus-SASL server, resulting in a Denial of Service even if the attacker is not able to authenticate.
Workaround :

There is no known workaround at this time.


All Cyrus-SASL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/cyrus-sasl-2.1.21-r2'

See Also

Plugin Details

Severity: Low

ID: 21255

File Name: gentoo_GLSA-200604-09.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/04/21

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cyrus-sasl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/04/21

Vulnerability Publication Date: 2006/04/07

Reference Information

CVE: CVE-2006-1721

OSVDB: 24510

GLSA: 200604-09