Firefox < 1.5.0.2 Multiple Vulnerabilities

High Nessus Plugin ID 21225

Synopsis

A web browser on the remote host is prone to multiple flaws.

Description

The remote Windows host is using Firefox, an alternative web browser.

The installed version of Firefox contains various security issues, some of which may lead to execution of arbitrary code on the affected host subject to the user's privileges.

Solution

Upgrade to Firefox 1.5.0.2 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2006-20/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-22/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-23/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-24/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-25/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-27/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-28/

https://www.mozilla.org/en-US/security/advisories/mfsa2006-29/

Plugin Details

Severity: High

ID: 21225

File Name: mozilla_firefox_1502.nasl

Version: 1.24

Type: local

Agent: windows

Family: Windows

Published: 2006/04/14

Updated: 2018/07/16

Dependencies: 20862

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/04/13

Vulnerability Publication Date: 2006/04/13

Reference Information

CVE: CVE-2006-0748, CVE-2006-1529, CVE-2006-1530, CVE-2006-1531, CVE-2006-1723, CVE-2006-1724, CVE-2006-1725, CVE-2006-1726, CVE-2006-1727, CVE-2006-1728, CVE-2006-1729, CVE-2006-1730

BID: 17516

CWE: 20, 189, 264, 399