Mandrake Linux Security Advisory : sash (MDKSA-2006:070)

High Nessus Plugin ID 21207


The remote Mandrake Linux host is missing a security update.


Tavis Ormandy of the Gentoo Security Project discovered a vulnerability in zlib where a certain data stream would cause zlib to corrupt a data structure, resulting in the linked application to dump core (CVE-2005-2096).

Markus Oberhumber discovered additional ways that a specially crafted compressed stream could trigger an overflow. An attacker could create such a stream that would cause a linked application to crash if opened by a user (CVE-2005-1849).

Both of these issues have previously been fixed in zlib, but sash links statically against zlib and is thus also affected by these issues. New sash packages are available that link against the updated zlib packages.


Update the affected sash package.

Plugin Details

Severity: High

ID: 21207

File Name: mandrake_MDKSA-2006-070.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/04/11

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:sash, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/04/10

Reference Information

CVE: CVE-2005-1849, CVE-2005-2096

MDKSA: 2006:070