Mandrake Linux Security Advisory : openvpn (MDKSA-2006:069)

High Nessus Plugin ID 21206


The remote Mandrake Linux host is missing a security update.


A vulnerability in OpenVPN 2.0 through 2.0.5 allows a malicious server to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.

Updated packages have been patched to correct this issue by removing setenv support.


Update the affected openvpn package.

Plugin Details

Severity: High

ID: 21206

File Name: mandrake_MDKSA-2006-069.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/04/11

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:openvpn, cpe:/o:mandriva:linux:2006

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/04/10

Reference Information

CVE: CVE-2006-1629

MDKSA: 2006:069