Ubuntu 5.04 / 5.10 : kaffeine vulnerability (USN-268-1)

Medium Nessus Plugin ID 21204


The remote Ubuntu host is missing one or more security-related patches.


Marcus Meissner discovered a buffer overflow in the http_peek() function. By tricking an user into opening a specially crafted playlist URL with Kaffeine, a remote attacker could exploit this to execute arbitrary code with the user's privileges.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected kaffeine, kaffeine-gstreamer and / or kaffeine-xine packages.

Plugin Details

Severity: Medium

ID: 21204

File Name: ubuntu_USN-268-1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: unix

Published: 2006/04/08

Modified: 2016/05/26

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:kaffeine, p-cpe:/a:canonical:ubuntu_linux:kaffeine-gstreamer, p-cpe:/a:canonical:ubuntu_linux:kaffeine-xine, cpe:/o:canonical:ubuntu_linux:5.04, cpe:/o:canonical:ubuntu_linux:5.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2006/04/06

Vulnerability Publication Date: 2006/04/04

Reference Information

CVE: CVE-2006-0051

OSVDB: 24377

USN: 268-1