GLSA-200604-05 : Doomsday: Format string vulnerability

High Nessus Plugin ID 21198


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200604-05 (Doomsday: Format string vulnerability)

Luigi Auriemma discovered that Doomsday incorrectly implements formatted printing.
Impact :

A remote attacker could exploit these vulnerabilities to execute arbitrary code with the rights of the user running the Doomsday server or client by sending specially crafted strings.
Workaround :

There is no known workaround at this time.


All Doomsday users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=games-fps/doomsday-1.9.0_beta4'

See Also

Plugin Details

Severity: High

ID: 21198

File Name: gentoo_GLSA-200604-05.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2006/04/08

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:doomsday, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/04/06

Vulnerability Publication Date: 2006/04/03

Reference Information

CVE: CVE-2006-1618

OSVDB: 24378

GLSA: 200604-05