Horde Help Viewer Arbitrary Code Execution

high Nessus Plugin ID 21164

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains a PHP application that allows execution of arbitrary PHP code.

Description

The version of Horde installed on the remote host fails to sanitize user-supplied input before using it in the Help viewer to evaluate code. An unauthenticated attacker could exploit this flaw to execute arbitrary command on the remote host subject to the privileges of the web server user id.

Solution

Upgrade to Horde 3.0.10 / 3.1.1 or later.

See Also

https://lists.horde.org/archives/announce/2006/000272.html

https://lists.horde.org/archives/announce/2006/000271.html

Plugin Details

Severity: High

ID: 21164

File Name: horde_help_viewer_code_exec.nasl

Version: 1.20

Type: remote

Family: CGI abuses

Published: 3/29/2006

Updated: 1/19/2021

Dependencies: horde_detect.nasl

Risk Information

VPR

Risk Factor: High

Score: 7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:horde:horde_application_framework

Required KB Items: www/horde

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 3/28/2006

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2006-1491

BID: 17292