Horde Help Viewer Arbitrary Code Execution

High Nessus Plugin ID 21164


The remote web server contains a PHP application that allows execution of arbitrary PHP code.


The version of Horde installed on the remote host fails to sanitize user-supplied input before using it in the Help viewer to evaluate code. An unauthenticated attacker could exploit this flaw to execute arbitrary command on the remote host subject to the privileges of the web server user id.


Upgrade to Horde 3.0.10 / 3.1.1 or later.

See Also



Plugin Details

Severity: High

ID: 21164

File Name: horde_help_viewer_code_exec.nasl

Version: 1.19

Type: remote

Family: CGI abuses

Published: 2006/03/29

Updated: 2018/06/13

Dependencies: 15604

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:horde:horde_application_framework

Required KB Items: www/horde

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2006/03/28

Exploitable With


Reference Information

CVE: CVE-2006-1491

BID: 17292