GLSA-200603-22 : PHP: Format string and XSS vulnerabilities

Medium Nessus Plugin ID 21129


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200603-22 (PHP: Format string and XSS vulnerabilities)

Stefan Esser of the Hardened PHP project has reported a few vulnerabilities found in PHP:
Input passed to the session ID in the session extension isn't properly sanitised before being returned to the user via a 'Set-Cookie' HTTP header, which can contain arbitrary injected data.
A format string error while processing error messages using the mysqli extension in version 5.1 and above.
Impact :

By sending a specially crafted request, a remote attacker can exploit this vulnerability to inject arbitrary HTTP headers, which will be included in the response sent to the user. The format string vulnerability may be exploited to execute arbitrary code.
Workaround :

There is no known workaround at this time.


All PHP 5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.1.2' All PHP 4.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-4.4.2'

See Also

Plugin Details

Severity: Medium

ID: 21129

File Name: gentoo_GLSA-200603-22.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/03/23

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:php, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2006/03/22

Vulnerability Publication Date: 2006/01/11

Reference Information

CVE: CVE-2006-0207, CVE-2006-0208

BID: 16220

OSVDB: 22478, 22480

GLSA: 200603-22