GLSA-200603-22 : PHP: Format string and XSS vulnerabilities
Medium Nessus Plugin ID 21129
SynopsisThe remote Gentoo host is missing one or more security-related patches.
DescriptionThe remote host is affected by the vulnerability described in GLSA-200603-22 (PHP: Format string and XSS vulnerabilities)
Stefan Esser of the Hardened PHP project has reported a few vulnerabilities found in PHP:
Input passed to the session ID in the session extension isn't properly sanitised before being returned to the user via a 'Set-Cookie' HTTP header, which can contain arbitrary injected data.
A format string error while processing error messages using the mysqli extension in version 5.1 and above.
By sending a specially crafted request, a remote attacker can exploit this vulnerability to inject arbitrary HTTP headers, which will be included in the response sent to the user. The format string vulnerability may be exploited to execute arbitrary code.
There is no known workaround at this time.
SolutionAll PHP 5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.1.2' All PHP 4.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-4.4.2'