GLSA-200603-19 : cURL/libcurl: Buffer overflow in the handling of TFTP URLs

High Nessus Plugin ID 21126


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200603-19 (cURL/libcurl: Buffer overflow in the handling of TFTP URLs)

Ulf Harnhammar reported a possible buffer overflow in the handling of TFTP URLs in libcurl due to the lack of boundary checks.
Impact :

An attacker could exploit this vulnerability to compromise a user's system by enticing the user to request a malicious URL with cURL/libcurl or to use a HTTP server redirecting to a malicious TFTP URL.
Workaround :

There is no known workaround at this time.


All cURL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/curl-7.15.1-r1'

See Also

Plugin Details

Severity: High

ID: 21126

File Name: gentoo_GLSA-200603-19.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/03/23

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:curl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/03/21

Vulnerability Publication Date: 2006/03/20

Reference Information

CVE: CVE-2006-1061

OSVDB: 23982

GLSA: 200603-19