GLSA-200603-13 : PEAR-Auth: Potential authentication bypass

High Nessus Plugin ID 21094


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200603-13 (PEAR-Auth: Potential authentication bypass)

Matt Van Gundy discovered that PEAR-Auth did not correctly validate data passed to the DB and LDAP containers.
Impact :

A remote attacker could possibly exploit this vulnerability to bypass the authentication mechanism by injecting specially crafted input to the underlying storage containers.
Workaround :

There is no known workaround at this time.


All PEAR-Auth users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-php/PEAR-Auth-1.2.4'

See Also

Plugin Details

Severity: High

ID: 21094

File Name: gentoo_GLSA-200603-13.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/03/18

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:PEAR-Auth, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/03/17

Vulnerability Publication Date: 2006/02/14

Reference Information

CVE: CVE-2006-0868

OSVDB: 23428

GLSA: 200603-13