MS06-012: Vulnerabilities in Microsoft Office Could Allow Remote Code Execution (905413)

high Nessus Plugin ID 21078

Synopsis

Arbitrary code can be executed on the remote host through Microsoft Office.

Description

The remote host is running a version of Microsoft Office that could allow arbitrary code to be run.

To succeed, the attacker would have to send a rogue file to a user of the remote computer and have him open it. Then a bug in the font parsing handler would result in code execution.

Solution

Microsoft has released a set of patches for Office 2000, XP and 2003.

See Also

https://docs.microsoft.com/en-us/security-updates/SecurityBulletins/2006/ms06-012

Plugin Details

Severity: High

ID: 21078

File Name: smb_nt_ms06-012.nasl

Version: 1.40

Type: local

Agent: windows

Published: 3/14/2006

Updated: 11/15/2018

Risk Information

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:office, cpe:/a:microsoft:excel, cpe:/a:microsoft:word, cpe:/a:microsoft:outlook, cpe:/a:microsoft:powerpoint, cpe:/a:microsoft:works

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/14/2006

Vulnerability Publication Date: 12/8/2005

Reference Information

CVE: CVE-2005-4131, CVE-2006-0028, CVE-2006-0029, CVE-2006-0030, CVE-2006-0031, CVE-2006-0009

BID: 15926, 16181, 17000, 17091, 17100, 17101, 17108

MSFT: MS06-012

MSKB: 905413, 905553, 905754, 905755, 905756, 905757