GLSA-200602-13 : GraphicsMagick: Format string vulnerability

Medium Nessus Plugin ID 20979


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200602-13 (GraphicsMagick: Format string vulnerability)

The SetImageInfo function was found vulnerable to a format string mishandling. Daniel Kobras discovered that the handling of '%'-escaped sequences in filenames passed to the function is inadequate in ImageMagick GLSA 200602-06 and the same vulnerability exists in GraphicsMagick.
Impact :

By feeding specially crafted file names to GraphicsMagick an attacker can crash the program and possibly execute arbitrary code with the privileges of the user running GraphicsMagick.
Workaround :

There is no known workaround at this time.


All GraphicsMagick users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/graphicsmagick-1.1.7'

See Also

Plugin Details

Severity: Medium

ID: 20979

File Name: gentoo_GLSA-200602-13.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/02/27

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:graphicsmagick, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2006/02/26

Vulnerability Publication Date: 2006/01/04

Reference Information

CVE: CVE-2006-0082

OSVDB: 22671

GLSA: 200602-13