SPIP < 1.8.2-g Multiple Vulnerabilities

high Nessus Plugin ID 20978
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server has a PHP application that is affected by multiple flaws.

Description

The remote host is running SPIP, an open source CMS written in PHP.

The remote version of this software is prone to SQL injection and cross-site scripting attacks. An attacker could send specially crafted URL to modify SQL requests, for example, to obtain the admin password hash, or execute malicious script code on the remote system.

Solution

Upgrade to SPIP version 1.8.2-g or later.

See Also

https://www.securityfocus.com/archive/1/423655/30/0/threaded

https://seclists.org/fulldisclosure/2006/Jan/993

Plugin Details

Severity: High

ID: 20978

File Name: spip_sql_injection.nasl

Version: 1.26

Type: remote

Family: CGI abuses

Published: 2/25/2006

Updated: 1/19/2021

Dependencies: http_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.3

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:spip:spip

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Vulnerability Publication Date: 1/31/2006

Reference Information

CVE: CVE-2006-0517, CVE-2006-0518, CVE-2006-0519

BID: 16458, 16461

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990