SPIP < 1.8.2-g Multiple Vulnerabilities

High Nessus Plugin ID 20978

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.3


The remote web server has a PHP application that is affected by multiple flaws.


The remote host is running SPIP, an open source CMS written in PHP.

The remote version of this software is prone to SQL injection and cross-site scripting attacks. An attacker could send specially crafted URL to modify SQL requests, for example, to obtain the admin password hash, or execute malicious script code on the remote system.


Upgrade to SPIP version 1.8.2-g or later.

See Also



Plugin Details

Severity: High

ID: 20978

File Name: spip_sql_injection.nasl

Version: 1.25

Type: remote

Family: CGI abuses

Published: 2006/02/25

Updated: 2020/06/12

Dependencies: 10107

Risk Information

Risk Factor: High

VPR Score: 5.3

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:spip:spip

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: false

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2006/01/31

Reference Information

CVE: CVE-2006-0517, CVE-2006-0518, CVE-2006-0519

BID: 16458, 16461

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990