Winamp < 5.2 Multiple Vulnerabilities

High Nessus Plugin ID 20973


A multimedia application that is vulnerable to denial of service attacks is installed on the remote Windows host.


The remote host is using Winamp, a popular media player for Windows.

The version of Winamp installed on the remote Windows host reportedly crashes if the user tries to open an M3U file with a long filename.

In addition, it reportedly contains a buffer overflow flaw that can be exploited using a specially crafted M3U file to either crash the application or possibly even execute arbitrary code remotely.


Upgrade to Winamp version 5.2 or later.

See Also

Plugin Details

Severity: High

ID: 20973

File Name: winamp_52.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2006/02/25

Modified: 2013/06/18

Dependencies: 15817

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/02/21

Vulnerability Publication Date: 2006/02/14

Reference Information

CVE: CVE-2006-0708, CVE-2006-0720

BID: 16623, 16785

OSVDB: 23265, 23525, 30142

EDB-ID: 26245