GLSA-200602-09 : BomberClone: Remote execution of arbitrary code

High Nessus Plugin ID 20935


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200602-09 (BomberClone: Remote execution of arbitrary code)

Stefan Cornelius of the Gentoo Security team discovered multiple missing buffer checks in BomberClone's code.
Impact :

By sending overly long error messages to the game via network, a remote attacker may exploit buffer overflows to execute arbitrary code with the rights of the user running BomberClone.
Workaround :

There is no known workaround at this time.


All BomberClone users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=games-action/bomberclone-'

See Also

Plugin Details

Severity: High

ID: 20935

File Name: gentoo_GLSA-200602-09.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/02/17

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:bomberclone, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/02/16

Vulnerability Publication Date: 2006/02/16

Exploitable With

Metasploit (Bomberclone 0.11.6 Buffer Overflow)

Reference Information

CVE: CVE-2006-0460

OSVDB: 23263

GLSA: 200602-09