Mandrake Linux Security Advisory : gnutls (MDKSA-2006:039)

High Nessus Plugin ID 20897


The remote Mandrake Linux host is missing one or more security updates.


Evgeny Legerov discovered cases of possible out-of-bounds access in the DER decoding schemes of libtasn1, when provided with invalid input. This library is bundled with gnutls.

The provided packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 20897

File Name: mandrake_MDKSA-2006-039.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2006/02/14

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnutls, p-cpe:/a:mandriva:linux:lib64gnutls11, p-cpe:/a:mandriva:linux:lib64gnutls11-devel, p-cpe:/a:mandriva:linux:libgnutls11, p-cpe:/a:mandriva:linux:libgnutls11-devel, cpe:/o:mandrakesoft:mandrake_linux:10.1, cpe:/o:mandriva:linux:2006, x-cpe:/o:mandrakesoft:mandrake_linux:le2005

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/02/13

Reference Information

CVE: CVE-2006-0645

MDKSA: 2006:039