GLSA-200602-06 : ImageMagick: Format string vulnerability

Medium Nessus Plugin ID 20896


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200602-06 (ImageMagick: Format string vulnerability)

The SetImageInfo function was found vulnerable to a format string mishandling. Daniel Kobras discovered that the handling of '%'-escaped sequences in filenames passed to the function is inadequate. This is a new vulnerability that is not addressed by GLSA 200503-11.
Impact :

By feeding specially crafted file names to ImageMagick, an attacker can crash the program and possibly execute arbitrary code with the privileges of the user running ImageMagick.
Workaround :

There is no known workaround at this time.


All ImageMagick users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=media-gfx/imagemagick-'

See Also

Plugin Details

Severity: Medium

ID: 20896

File Name: gentoo_GLSA-200602-06.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2006/02/14

Modified: 2018/01/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:imagemagick, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2006/02/13

Vulnerability Publication Date: 2006/01/04

Reference Information

CVE: CVE-2006-0082

BID: 12717

OSVDB: 22671

GLSA: 200602-06