Mandrake Linux Security Advisory : kdelibs (MDKSA-2006:019)

High Nessus Plugin ID 20797


The remote Mandrake Linux host is missing one or more security updates.


A heap overflow vulnerability was discovered in kjs, the KDE JavaScript interpretter engine. An attacker could create a malicious web site that contained carefully crafted JavaScript code that could trigger the flaw and potentially lead to the arbitrary execution of code as the user visiting the site.

The updated packages have been patched to correct this problem.


Update the affected packages.

Plugin Details

Severity: High

ID: 20797

File Name: mandrake_MDKSA-2006-019.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2006/01/22

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:kdelibs-common, p-cpe:/a:mandriva:linux:kdelibs-devel-doc, p-cpe:/a:mandriva:linux:lib64kdecore4, p-cpe:/a:mandriva:linux:lib64kdecore4-devel, p-cpe:/a:mandriva:linux:libkdecore4, p-cpe:/a:mandriva:linux:libkdecore4-devel, cpe:/o:mandriva:linux:2006

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2006/01/20

Reference Information

CVE: CVE-2006-0019

MDKSA: 2006:019