Ubuntu 5.04 / 5.10 : kdelibs vulnerability (USN-245-1)

High Nessus Plugin ID 20792


The remote Ubuntu host is missing one or more security-related patches.


Maksim Orlovich discovered that kjs, the JavaScript interpreter engine used by Konqueror and other parts of KDE, did not sufficiently verify the validity of UTF-8 encoded URIs. Specially crafted URIs could trigger a buffer overflow. By tricking an user into visiting a website with malicious JavaScript code, a remote attacker could exploit this to execute arbitrary code with user privileges.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: High

ID: 20792

File Name: ubuntu_USN-245-1.nasl

Version: $Revision: 1.15 $

Type: local

Agent: unix

Published: 2006/01/21

Modified: 2016/05/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:kdelibs, p-cpe:/a:canonical:ubuntu_linux:kdelibs-bin, p-cpe:/a:canonical:ubuntu_linux:kdelibs-data, p-cpe:/a:canonical:ubuntu_linux:kdelibs4, p-cpe:/a:canonical:ubuntu_linux:kdelibs4-dev, p-cpe:/a:canonical:ubuntu_linux:kdelibs4-doc, p-cpe:/a:canonical:ubuntu_linux:kdelibs4c2, p-cpe:/a:canonical:ubuntu_linux:kdelibs4c2-dbg, cpe:/o:canonical:ubuntu_linux:5.04, cpe:/o:canonical:ubuntu_linux:5.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2006/01/20

Vulnerability Publication Date: 2006/01/19

Reference Information

CVE: CVE-2006-0019

OSVDB: 22659

USN: 245-1