Ubuntu 4.10 : curl vulnerability (USN-86-1)

Medium Nessus Plugin ID 20711


The remote Ubuntu host is missing one or more security-related patches.


infamous41md discovered a buffer overflow in cURL's NT LAN Manager (NTLM) authentication handling. By sending a specially crafted long NTLM reply packet, a remote attacker could overflow the reply buffer.
This could lead to execution of arbitrary attacker specified code with the privileges of the application using the cURL library.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 20711

File Name: ubuntu_USN-86-1.nasl

Version: $Revision: 1.19 $

Type: local

Agent: unix

Published: 2006/01/15

Modified: 2016/05/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:curl, p-cpe:/a:canonical:ubuntu_linux:libcurl2, p-cpe:/a:canonical:ubuntu_linux:libcurl2-dbg, p-cpe:/a:canonical:ubuntu_linux:libcurl2-dev, p-cpe:/a:canonical:ubuntu_linux:libcurl2-gssapi, cpe:/o:canonical:ubuntu_linux:4.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2005/02/28

Reference Information

CVE: CVE-2005-0490

USN: 86-1